Uploaded image for project: 'Geode'
  1. Geode
  2. GEODE-7844

Refactor sendMsgByBucket and sendClearMsgByBucket not to use duplicated code

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: core
    • Labels:

      Description

      In PartitionedRegion class, there're 2 sendMsgByBucket() methods, one for PutAll, another is for RemoveAll. We are adding the 3rd one for Clear.

      Their logic are duplicated in most part. Need to refactor the 3 methods to avoid duplicate code.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                zhouxj Xiaojian Zhou
                Reporter:
                zhouxj Xiaojian Zhou
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: