Uploaded image for project: 'Geode'
  1. Geode
  2. GEODE-6532

Convert compile dependencies to implementation/api dependencies

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: build, docs
    • Labels:
      None

      Description

      The compile configuration has been deprecated for some time. api will behave similarly, whereas implementation will appear to be a runtime dependency to consumers.

      This will require examining our public API so that we may correctly declare which dependencies are api. When a PR is made, an email should be sent to the dev@ and/or user@ lists warning that those consuming internal APIs (against best practice) may experience breakages if their own dependencies are not properly declared. Similarly, a release note on this topic could be helpful to those upgrading.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                upthewaterspout Dan Smith
                Reporter:
                prhomberg Patrick Rhomberg
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 2h 20m
                  2h 20m