Uploaded image for project: 'Geode'
  1. Geode
  2. GEODE-10045

Upgrade to Micrometer 2.0

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Invalid
    • 1.14.4
    • None
    • core

    Description

      As part of the ongoing story and themes in Spring Framework 6, Spring Data 3.0, Spring Boot 3.0 and the rest of the Spring portfolio, 1 of the new and major topics is Observability (Metrics and Monitoring, with Tracing, and so on).

      As part of that effort, Micrometer is undergoing a major revision change from 1.x to 2.0. Many of their APIs have changed, and as a result, Apache Geode no longer runs (or even will build) with Micrometer 2.0.

      Either Micrometer should be upgraded to 2.0 (most likely in the next major version of Geode, i.e. 2.0) or Micrometer should be an optional dependency, perhaps only enabled when Micrometer is on the classpath.

      Still a cleaner separation is needed if [Spring] Apache Geode users require and use a newer version of Micrometer (e.g. 2.0) and Apache Geode remains on Micrometer 1.x (currently 1.6.3 in Apache Geode 1.14.3).

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            jblum John Blum
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment