FtpServer
  1. FtpServer
  2. FTPSERVER-318

Subclasses of FtpException ignore the Throwable parameter in their constructors

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.2
    • Fix Version/s: 1.0.3, 1.1.0
    • Component/s: Core, Ftplets
    • Labels:
      None

      Description

      Currently there are two subclasses of FtpException -

      1) AuthenticationFailedException
      2) DataConnectionException

      The constructors AuthenticationFailedException(String msg, Throwable th) and DataConnectionException(final String msg, final Throwable th) ignore (do not use) the second parameter, "th". The parameter "th" should be passed to the constructor of super class to have accurate stack trace.

      Also, out of curiosity, why does the FtpException has a member variable named "throwable" for storing the cause instead of using the cause defined in java.lang.Throwable? Why were the printStackTrace methods overridden?

        Activity

        Niklas Gustavsson added a comment -

        Fixed in rev 817215. Also removed the ancient handling of the causing exception and deprecated the FtpException.getRootCause() method.


          People

          • Assignee:
            Niklas Gustavsson
            Reporter:
            Sai Pullabhotla
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development