Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0-M4
    • Fix Version/s: 1.0.0-RC1
    • Component/s: Core
    • Labels:
      None

      Description

      Not sure if TYPE command with no argument should change the type to ASCII. Instead it should reply back with 2xx reply indicating the current type in use. Not sure what the RFC says.

        Activity

        Hide
        David Latorre added a comment -

        Makes sense.RFC doesn't list the first parameter as optional.
        Fix will be provided for 1.0.0-RC1.

        Show
        David Latorre added a comment - Makes sense.RFC doesn't list the first parameter as optional. Fix will be provided for 1.0.0-RC1.
        Hide
        Niklas Gustavsson added a comment -

        We do not default to ASCII, we send a 501 if the argument is missing. This seems similar to ProFTPD (send 500). I've added a test case to make sure we maintain this behavior.

        Show
        Niklas Gustavsson added a comment - We do not default to ASCII, we send a 501 if the argument is missing. This seems similar to ProFTPD (send 500). I've added a test case to make sure we maintain this behavior.
        Hide
        Niklas Gustavsson added a comment -

        Test case added in rev 725442.

        Show
        Niklas Gustavsson added a comment - Test case added in rev 725442.

          People

          • Assignee:
            Niklas Gustavsson
            Reporter:
            Sai Pullabhotla
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development