FtpServer
  1. FtpServer
  2. FTPSERVER-20

Functions for command line start up moved out of FtpServer class

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Command line execution environment.

      Description

      The attached patch moves the functions related with the start up of the FtpServer application out of the FtpServer class.

      I have created a new class named CommandLine to host this functions and it is in the package org.apache.ftpserver.commandline

      This patch was develop agains the latest CVS code, but I am not sure it is compatible with the patches in the open issues.

      1. CommandLine.java
        5 kB
        Luis Sanabria
      2. commandline.txt
        6 kB
        Luis Sanabria

        Activity

        Rana Bhattacharyya made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Rana Bhattacharyya added a comment -

        Applied patch - the issue is closed

        Luis Sanabria added a comment -

        Thanks.

        Feel free to close this issue.

        Rana Bhattacharyya added a comment -

        Applied patch and commited files in SVN

        Luis Sanabria made changes -
        Attachment CommandLine.java [ 12314942 ]
        Luis Sanabria added a comment -

        New CommandLine class

        Luis Sanabria made changes -
        Field Original Value New Value
        Attachment commandline.txt [ 12314941 ]
        Luis Sanabria added a comment -

        Changes in the FtpServer class.

        Luis Sanabria created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Luis Sanabria
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development