FtpServer
  1. FtpServer
  2. FTPSERVER-195

Some boolean properties of FtpFile are not accessibile with the JavaBean isFoo()

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.0-M4
    • Component/s: None
    • Labels:
      None

      Description

      We have three properties that do not follow the JavaBean convention:

      public interface FtpFile {
      boolean hasReadPermission();
      boolean hasWritePermission();
      boolean hasDeletePermission();
      ...
      }

      They could be renamed as

      public interface FtpFile {
      boolean isReadable();
      boolean isWritable();
      boolean isRemovable();
      ...
      }

      Using the JavaBean convetion for properties allow interoperability with code that uses bean introspection to access to object classes.

        Activity

        Hide
        Emmanuel Lecharny added a comment -

        Makes sense !

        Can you provide a patch for such a modification ? When it's obvious, simply applying a patch is certainly faster than modifying the code

        Show
        Emmanuel Lecharny added a comment - Makes sense ! Can you provide a patch for such a modification ? When it's obvious, simply applying a patch is certainly faster than modifying the code
        Hide
        Niklas Gustavsson added a comment -

        Too late Emmanuel, I fixed it now in rev 704607. But, patches are of course welcome for all bugs. Thanks for reporting this one.

        Show
        Niklas Gustavsson added a comment - Too late Emmanuel, I fixed it now in rev 704607. But, patches are of course welcome for all bugs. Thanks for reporting this one.
        Hide
        Andrea Francia added a comment -

        Sorry but I have little time to dedicate to non-work projects and yesterday my netbeans 6.5 had some problems.

        I'm not sure about the isRemovable() method name I suggested because the rfc959 usese the "delete" verb and the DELE command for files, even if it uses "remove" (and RMD) for directories. But the FtpFile represents both. And the english words "remove" and "delete" are not true synonym. I don't know but I don't think it's so important.

        Show
        Andrea Francia added a comment - Sorry but I have little time to dedicate to non-work projects and yesterday my netbeans 6.5 had some problems. I'm not sure about the isRemovable() method name I suggested because the rfc959 usese the "delete" verb and the DELE command for files, even if it uses "remove" (and RMD) for directories. But the FtpFile represents both. And the english words "remove" and "delete" are not true synonym. I don't know but I don't think it's so important.

          People

          • Assignee:
            Niklas Gustavsson
            Reporter:
            Andrea Francia
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development