Forrest
  1. Forrest
  2. FOR-963

generated Plugins Index has hard-coded version URL to plugins docs

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8
    • Fix Version/s: 0.8
    • Labels:
      None

      Description

      The stylesheet that generates the Plugins Index page has a hard-coded URL to the "Extending Forrest with Plugins" documentation. Our template sites (e.g. main/fresh-site) also refer to this generated documentation. It is a clever capability demo.

      However, this causes a maintenance issue in the lead-up to each release.

        Activity

        David Crossley added a comment -
        Passing a parameter for pluginDocsVersion from sitemap.xmap to plugins-to-xdoc.xsl enables automatic construction of the full URL for the relevant version of the plugin docs.
        David Crossley added a comment -
        The issue is even more complex because the same stylesheet is used to generate both pluginDocs/plugins_0_70/index.html and pluginDocs/plugins_0_80/index.html (e.g. see r515857) and later the 0.90 page. So the URL will be incorrect in one or the other, despite whether we use a hard-coded full URL or a site: URL.
        David Crossley added a comment -
        This could be replaced with a "site:" URI (i.e. site:plugins/using). That works for our "site-author" because it has a matching entry in the site.xml config. However, the template sites (e.g. main/fresh-site) do not have such an entry.

          People

          • Assignee:
            Unassigned
            Reporter:
            David Crossley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development