Uploaded image for project: 'Forrest'
  1. Forrest
  2. FOR-66

Some pages not rendered from command-line

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 0.5, 0.6
    • Fix Version/s: 0.5.1
    • Component/s: Launch 'forrest'
    • Labels:
      None

      Description

      At least three users have now reported that Forrest does not render all pages in a site, if a custom skin is used. It seems that some links are not crawled, although they are traversable through the webapp. No errors or broken links are shown in the CLI.

      The last Forrest version that didn't have this problem was tagged 'stable-20030626'.

      A possible workaround would be to revert to the old command-line processing method, by editing forrest.build.xml.

        Issue Links

          Activity

          Hide
          jefft Jeff Turner added a comment -
          Linking to the broken credit link bug, which is likely due to the same cause
          Show
          jefft Jeff Turner added a comment - Linking to the broken credit link bug, which is likely due to the same cause
          Hide
          jefft Jeff Turner added a comment -
          The new Cocoon version committed to CVS head and 0.5 branch seems to have fixed this for me. Please test..
          Show
          jefft Jeff Turner added a comment - The new Cocoon version committed to CVS head and 0.5 branch seems to have fixed this for me. Please test..

            People

            • Assignee:
              jefft Jeff Turner
              Reporter:
              jefft Jeff Turner
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development