Forrest
  1. Forrest
  2. FOR-65

forrest-site skin does not render correclty on Opera

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 0.5.1
    • Component/s: Skins (general issues)
    • Labels:
      None
    • Environment:
      Tested on Opera 7.01

      Description

      When running on Opera, the forrest-site skin does not render correctly: the content only consumes about 50% of the available space. On IE (tested with IE 5.5), everything is fine.

        Activity

        Peter Friese added a comment -
        forrest-site skin on Opera
        Peter Friese added a comment -
        forrest-site skin on IE: everything is fine
        Peter Friese added a comment -
        The problem is caused by a sloppy piece of HTML in the site2xhtml.xsl script.

        The middle navbar (lines 151 to 174) is made up of 4 td's whereas the content row (lines 177 to 185) is made up of only 3 td's. The problem can be resolved by patching line 180:

        line 180 before:
        <td width="100%" align="left">

        line 180 after:
        <td width="100%" align="left" colspan="2">
        Peter Friese added a comment -
        Attached the patched site2xhtml.xsl file.
        Jeff Turner added a comment -
        Patch applied, thanks. Fix will be in 0.5.1 release

          People

          • Assignee:
            Unassigned
            Reporter:
            Peter Friese
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development