Forrest
  1. Forrest
  2. FOR-581

Toolbar icons not found if tool is installed in user config dir

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.8
    • Fix Version/s: 0.8
    • Component/s: Tool: XXE config
    • Labels:
      None

      Description

      The XXE tool is referencing several icons in the XXE distribution in a way that requires the tool to be installed within the application directory structure.

      As of version 2.10 (or was it 2.9p1?), the user config dir is a replica of the application config dir, and is scanned upon application startup. This makes it natural to install the forrest XXE tool in the user space, to avoid having to reinstall it each time XXE is updated.

      Because the icon references are relative to the installation dir of XXE (and assuming that the tool is installed at a certain directory depth within it), it is presently not possible to install the tool in the XXE user config area. The tool initialisation will crash, which again will turn off the tool.

      A simple solution would be to just copy the icons into the forreset tool, but I have been unable to find any license text or any other description on whether that would be acceptable.

      Another solution would be to enhance the URI of the icons with a reference to the installation directory, but I don't know whether there exists a mechanism that would allow the necessary platform independence and flexibility.
      1. tools.xxe.doc-update.txt
        2 kB
        Sjur N. Moshagen
      2. tools.xxe.icon-ref-patch.txt
        11 kB
        Sjur N. Moshagen

        Issue Links

          Activity

          David Crossley added a comment -
          Thanks. Especially so for the thorough work and the useful issue descriptions.
          Sjur N. Moshagen added a comment -
          The tool is also updated to version 1.3 with the recent fixes and changes.
          Sjur N. Moshagen added a comment -
          A patch to update the online docs (0.8-dev) to reflect the changes made.
          Sjur N. Moshagen added a comment -
          The attached file patches all files necessary to fix the bugs in this issue.

          It also includes the patch submitted for FOR-720.

          Beyond mere bug fixes, the patch also includes the following enhancements, documented in the README file:
          - Added a Forrest menu, with more robust table manipulation, and for v2 docs some link traversals (both taken from the XXE XHTML config)
          - Added more entries to the Table button (menu) in the Forrest toolbar, replicating the entries in the Forrest menu
          Sjur N. Moshagen added a comment -
          There is a similar issue with loading the common.css stylesheet when opening/creating a Forrest document. Presently the two files

          tools/xxe/forrest/css/document1x.css
          tools/xxe/forrest/css/document2x.css

          contains the following @import statement:

          @import url(xxe-config:forrest/css/common.css);

          If changed to:

          @import url(common.css);

          the problem is gone.

            People

            • Assignee:
              Unassigned
              Reporter:
              Sjur N. Moshagen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development