Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.7, 0.8
    • Fix Version/s: 0.8
    • Labels:
      None

      Description

      The forrestbot documentation is not entirely clear to people not very familiar with ant and forrestbot workings. Some clarification for dummies like me would be much appreciated to make forrestbot implementation a little less painful.
      1. forrestbot.xml.diff2
        17 kB
        Richard Calmbach
      2. forrestbot.xml.diff
        7 kB
        Addison Berry

        Activity

        add1sun Addison Berry added a comment -
        Here is a first crack at the forrestbot documentation. It has quite a few fixmes with questions. I rearranged some of the existing content because it seemed disjointed and out of order in places - to me at least. One fixme question I forgot to include in the file is that there is no indication of where to save the new buildfile you create. I've found it works from most anywhere on my linux box but some direction in the docs would be a Very Good Thing.
        crossley David Crossley added a comment -
        Thanks, applied patch "1. forrestbot.xml.diff (7 kb)".

        I then did a subsequent commit to convert tabs to spaces (please keep the same whitespace treament as the file already has). I also wrapped long lines. This is important, otherwise future diffs are impossible to read when paragraphs are one long line.
        crossley David Crossley added a comment -
        Too hasty, the issue is not fixed, Addi's initial patch helped, but much more is needed. There is some recent discussion in the mail archives, from which some words can be gleaned.
        rcalmbac Richard Calmbach added a comment -
        Attachment forrestbot.xml.diff2 is a patch against the current SVN HEAD (rev. 353958). After delving into the Forrestbot implementation, I felt I understand Forrestbot enough to be able to clarify the documentation a bit. I addressed all the fixmes and added a section on a gotcha with 'getsrc.local' that caused me to go digging into Forrestbot internals in the first place.
        rgardler Ross Gardler added a comment -
        Applied, with thanks.

        Please note that the diff was incorrectly made. It was against a file called forrest.xml.orig and therefore could not be applied without manual interention.

        Please provide all patches against the latest SVN version - see http://forrest.apache.org/contrib.html#patch

        Once again, thank you for your contribution - very valuable.

          People

          • Assignee:
            rgardler Ross Gardler
            Reporter:
            add1sun Addison Berry
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development