Forrest
  1. Forrest
  2. FOR-549

plugin DTD catalogs are not included when running as a servlet WAR

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 0.7, 0.8
    • Fix Version/s: 0.7, 0.8
    • Component/s: Launch servlet WAR
    • Labels:
      None

      Description

       When using a WAR file under a full Jetty, the plugins catalog.xcat files are not being included. In the webapp, the path to build/plugins/ is different.

        Activity

        David Crossley created issue -
        David Crossley added a comment -
        The solution is to add an additional path to main/webapp/resources/schema/catalog.xcat
        like this ...
        <nextCatalog catalog="../../build/plugins/catalog.xcat"/>
        David Crossley made changes -
        Field Original Value New Value
        Fix Version/s 0.7 [ 12310031 ]
        Affects Version/s 0.8-dev [ 12310040 ]
        Fix Version/s 0.8-dev [ 12310040 ]
        David Crossley added a comment -
        The two different paths were added to the core catalog.

        This is a workaround, so the issue is marked as Incomplete
        David Crossley made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Incomplete [ 4 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            David Crossley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development