Forrest
  1. Forrest
  2. FOR-518

Change toolbox font in skinconf.xml for pelt

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.7
    • Fix Version/s: 0.8
    • Component/s: Skins (general issues)
    • Labels:
      None
    • Other Info:
      Patch available

      Description

      Users can set the background color for toolbox in skincof.xml but they there is no option to set the font color. Users must go in and manually edit site/skin/profile.css.
      1. toolbox-font.txt
        2 kB
        Addison Berry
      2. skinconf.xml.diff
        0.8 kB
        Addison Berry
      3. profile.css.xslt.diff
        0.9 kB
        Addison Berry

        Activity

        Ross Gardler added a comment -
        Most of this functionality had already made it in. Seems someone forgot to close the issue.
        Addison Berry added a comment -
        These patches (two files) appear to work fine now. If you uncomment the color group: Forrest in skinconf.xml in a newly seeded site the toolbox default is now:
            <color name="toolbox" value="#4a6d8c" font="#FFFFFF"/>
        and users can edit the font as well as background color. (I set the default font to white because black is too hard to see against forrest's dark blue background.)
        Addison Berry added a comment -
        Last night I fixed this by editing the pelt/css/profile.css.xslt file by moving #menu .menupagetitle {color: <xsl:value-of select="@font"/>;} up to toolbox, rather than where it was in dialog (since dialog doesn't seem to be used in pelt?) and also adding the font attribute to the toolbox color element in fresh-site/skinconf.xml. Worked just the way I wanted. See the attached diffs.

        When I did a build clean, build on a new svn today, I am now getting an error when I try to forrest site:
        X [0] linkmap.html BROKEN: The content of elements must consist of well-formed character data or markup.

        I'm not sure what the problem is now...

          People

          • Assignee:
            Unassigned
            Reporter:
            Addison Berry
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development