Forrest
  1. Forrest
  2. FOR-293

HTML links and menus are not being generated properly

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 0.6
    • Component/s: Skins (general issues)
    • Labels:
      None

      Description

      The left side menus and generated links are very messed up in both the pelt and tigris skins.

      Best way to describe this is simply to SVN checkout the head (or revision 46191) and do a "forrest seed site". Try it under both the default pelt and tigris skins.

      The tigris skin makes the menu / generated link problem quite clear.

        Activity

        Hide
        Nicola Ken Barozzi added a comment -
        <banging-head-on-the-wall>
          I had somehow managed to commit a wrong fix, not inserting a
          complete identity transform template. Sorry :-/
        </banging-head-on-the-wall>
        Show
        Nicola Ken Barozzi added a comment - <banging-head-on-the-wall>   I had somehow managed to commit a wrong fix, not inserting a   complete identity transform template. Sorry :-/ </banging-head-on-the-wall>
        Hide
        Rick Tessner added a comment -
        A better temporary fix would be just to go back to revision 46171 using whatever SVN client you have.

        Command line: svn update -r 46171
        Show
        Rick Tessner added a comment - A better temporary fix would be just to go back to revision 46171 using whatever SVN client you have. Command line: svn update -r 46171
        Hide
        Rick Tessner added a comment -
        It looks like it's the change from 46171 - 46175 is the culprit, which was a temporary fix for FOR-284.

        A quick fix is to undo that particular change. If you're on a *nix type system and you've checked out forrest via svn, cd to the top level directory where you have forrest and then do a:

        svn diff -r 46175:46171 | patch -p0

        This creates a (reverse) diff and patches your current implementation.

        A that point, do a:

        ./build.sh clean ; ./build.sh

        Rebuild your site.
        Show
        Rick Tessner added a comment - It looks like it's the change from 46171 - 46175 is the culprit, which was a temporary fix for FOR-284 . A quick fix is to undo that particular change. If you're on a *nix type system and you've checked out forrest via svn, cd to the top level directory where you have forrest and then do a: svn diff -r 46175:46171 | patch -p0 This creates a (reverse) diff and patches your current implementation. A that point, do a: ./build.sh clean ; ./build.sh Rebuild your site.

          People

          • Assignee:
            Unassigned
            Reporter:
            Rick Tessner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development