Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 0.6
    • Component/s: None
    • Labels:
      None

      Description

      Margins for PDF pages seemed to be ignored.
      I use the default of
      <pdf>
          <page size="letter" orientation="portrait"/>

          <margins double-sided="false">
            <top>1in</top>
            <bottom>1in</bottom>
            <inner>1.25in</inner>
            <outer>1in</outer>
          </margins>
        </pdf>

      But the margins are always zero.

        Activity

        Nick Chalko created issue -
        Florian G. Haas added a comment -
        I just had a look into this. Apparently the skinconf.xml is being ignored altogether. The currently implemented method of getting to the $config variable in analogy to the HTML stylesheets (i.e. using the //skinconfig XPath) won't work here. The sitemap still tries to pass the config-file parameter and there is no content aggregation as there is with HTML.

        However, reverting the stylesheet to honoring the config-file parameter and using the document() function doesn't work either. The config-file param is resolved correctly to point to the skinconf.xml located in build/webapp, but the document() function fails to retrieve the document node.

        Could this be the same issue Bryan Hayes talked about in the thread titled "[Issue] Rev 10206 - Is skinconf being processed?" starting Apr 24? The thread itself seems inconclusive -- Cheche, do you have any new findings you could share?

        I haven't checked, but I'm pretty sure that FOR-139 is a duplicate of this (also being a result of the skinconf file being ignored).
        Juan Jose Pablos added a comment -
        The way that //skinconfig is available is just for *.html.
        Until we settle down the definition of the skinconf I have just revert them
        Juan Jose Pablos made changes -
        Field Original Value New Value
        Status Assigned Closed
        issue.field.fixfor 0.6
        Resolution Fixed
        Thorsten Scherler added a comment -
        I think that the issue is still open, because the information of the skinconf.xml are still ignored in PDF.
        Dave Brondsema made changes -
        Status Closed Assigned
        Resolution Fixed  
        Dave Brondsema made changes -
        Resolution Fixed
        Status Assigned Closed

          People

          • Assignee:
            Unassigned
            Reporter:
            Nick Chalko
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development