Forrest
  1. Forrest
  2. FOR-10

build dist fails (both in windows-cmd and cygwin)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Compile
    • Labels:
      None
    • Environment:
      win2k with cygwin and cmd
      no clue which version of forest cvs got on my c:

      Description

      1) cygwin:
      rhauser@RHAUSERPCGF590K:~/<3>apache_forrest/xml-forrest> ./build.sh dist
      Using classpath: "./lib/endorsed/xalan-2.4.1.jar;./lib/endorsed/xercesImpl-2.1.0
      .jar;./lib/endorsed/xml-apis.jar;./lib/endorsed/xsltc.jar"
      C:\Data\MyDocRalf\bin\cgywin\bin\cygpath.exe: *** can't create title mutex, Win32 error 6
      Error: JAVA_HOME is not defined correctly.
        We cannot execute java
      rhauser@RHAUSERPCGF590K:~/<3>apache_forrest/xml-forrest>

      Any idea what happened? Otherwise, I can run ant and other java stuff without problems. Since I updated to cygwin1.18, man doesn't find all
      directories in the man path anymore - perhaps this mutex is a cygwin problem and has notthing to do with forrest?

      2) Win32 cmd:
      C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest>build dist
      Using classpath: ";.\lib\endorsed\xalan-2.4.1.jar;.\lib\endorsed\xercesImpl-2.1.
      0.jar;.\lib\endorsed\xml-apis.jar;.\lib\endorsed\xsltc.jar"
      Buildfile: build.xml

      init:

            --------------------------------------------------------------

            Using Apache Ant version 1.6alpha compiled on December 1 2002
            Build file C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest\build.xml

            Build system home tools\ant
            Build number 0
            Project Name Forrest build file
            Java Version 1.3
            Timestamp 200301091951

            --------------------------------------------------------------

      Created dir: C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest\build

      validate-config:
      validating **/skinconf.xml ...
      Fatal error: exception "java.io.FileNotFoundException" thrown: C:\Data\MyDocRalf
      \bin\Java\apache_forrest\xml-forrest\src\resources\schema\relaxng\skinconf-v10.rng (The system cannot find the file specified)

      BUILD FAILED
      file://C:/Data/MyDocRalf/bin/Java/apache_forrest/xml-forrest/build.xml:305: Vali
      dation failed, messages should have been provided.

      Total time: 4 seconds

      C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest>

      It appears that there is a typo - I do have a skinconf.rnc, but not skinconf.rn*G*

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Ralf Hauser
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development