Forrest
  1. Forrest
  2. FOR-10

build dist fails (both in windows-cmd and cygwin)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Compile
    • Labels:
      None
    • Environment:
      win2k with cygwin and cmd
      no clue which version of forest cvs got on my c:

      Description

      1) cygwin:
      rhauser@RHAUSERPCGF590K:~/<3>apache_forrest/xml-forrest> ./build.sh dist
      Using classpath: "./lib/endorsed/xalan-2.4.1.jar;./lib/endorsed/xercesImpl-2.1.0
      .jar;./lib/endorsed/xml-apis.jar;./lib/endorsed/xsltc.jar"
      C:\Data\MyDocRalf\bin\cgywin\bin\cygpath.exe: *** can't create title mutex, Win32 error 6
      Error: JAVA_HOME is not defined correctly.
        We cannot execute java
      rhauser@RHAUSERPCGF590K:~/<3>apache_forrest/xml-forrest>

      Any idea what happened? Otherwise, I can run ant and other java stuff without problems. Since I updated to cygwin1.18, man doesn't find all
      directories in the man path anymore - perhaps this mutex is a cygwin problem and has notthing to do with forrest?

      2) Win32 cmd:
      C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest>build dist
      Using classpath: ";.\lib\endorsed\xalan-2.4.1.jar;.\lib\endorsed\xercesImpl-2.1.
      0.jar;.\lib\endorsed\xml-apis.jar;.\lib\endorsed\xsltc.jar"
      Buildfile: build.xml

      init:

            --------------------------------------------------------------

            Using Apache Ant version 1.6alpha compiled on December 1 2002
            Build file C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest\build.xml

            Build system home tools\ant
            Build number 0
            Project Name Forrest build file
            Java Version 1.3
            Timestamp 200301091951

            --------------------------------------------------------------

      Created dir: C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest\build

      validate-config:
      validating **/skinconf.xml ...
      Fatal error: exception "java.io.FileNotFoundException" thrown: C:\Data\MyDocRalf
      \bin\Java\apache_forrest\xml-forrest\src\resources\schema\relaxng\skinconf-v10.rng (The system cannot find the file specified)

      BUILD FAILED
      file://C:/Data/MyDocRalf/bin/Java/apache_forrest/xml-forrest/build.xml:305: Vali
      dation failed, messages should have been provided.

      Total time: 4 seconds

      C:\Data\MyDocRalf\bin\Java\apache_forrest\xml-forrest>

      It appears that there is a typo - I do have a skinconf.rnc, but not skinconf.rn*G*

        Activity

        Ralf Hauser added a comment -
        sure, please close the issue and we hope that cygwin soon takes the fix back into their regular distribution - thus the traffic for that FAQ entry hopefully soon levels off...
        Jeff Turner added a comment -
        Okay, I'll mark the bug as closed, and add a FAQ entry linking to this report.

        --Jeff
        Ralf Hauser added a comment -
        Fergus, the mail-archive I cited before still applies - (see http://www.mail-archive.com/cygwin@cygwin.com/msg15342.html)
        and then I got cygwin1.dll and cygpath.exe from http://cygwin.com/snapshots/cygwin-inst-20030119.tar and directly installed them in the /bin
        It appears that there are newer posts on the topic in the mailing list - perhaps they have better solutions. If this approach works for you or you find better solutions, please
        1) inform me
        2) post it to the mailing list such that others will easily find it.

        P.S.: I still have problems with man using version j, it no longer finds all elements of my manpath, if I use version g, all files are found, but the rendering fails - I now get a lot of
        <<FTP(1) BSD General Commands Manual

        ESC[1mNAMEESC[0m
             ESC[1mftp ESC[22m- ARPANET file transfer program

        ESC[1mSYNOPSISESC[0m>>
        Have you experienced the same?
        Fergus Henderson added a comment -
        I got a similar error ("C:\cygwin\bin\cygpath.exe: *** can't create title mutex, Win32 error 6)" when compiling a completely different
        package, namely Mercury 0.11.0 <http://www.cs.mu.oz.au/mercury/&gt;,
        with Cygwin. The error was reproduceable. It looks very much
        like this is a Cygwin bug rather than anything to do with Apache
        or Mercury.

        If you figure out how to fix it or even work around it,
        please let me (fjh at cs.mu.oz.au) know!
        Steven Noels added a comment -
        So, can we close this issue?
        Ralf Hauser added a comment -
        o.k., seems to work now!
        Jeff Turner added a comment -
        Apologies, the second error (skinconf-v10.rng not found) is my fault. Updating from CVS should fix this. If you're offline, edit build.xml, line 515:
        - <jing rngfile="./src/resources/schema/relaxng/skinconf-v10.rng">
        + <jing compactSyntax="true" rngfile="./src/resources/schema/relaxng/skinconf.rnc">


        --Jeff
        Ralf Hauser added a comment -
        O.k. I am seeing that cygwin problem all over with no solution yet:
        http://www.mail-archive.com/cygwin@cygwin.com/msg15342.html etc.

        But when I am using a non-alpha "ant" by replacing in the build.sh

        #"$PWD/./tools/ant/bin/ant" -emacs $@
        ant -emacs $@

        I get as far as I do with windows (with almost the same messages):
        <<rhauser@RHAUSERPCGF590K:~/<3>apache_forrest/xml-forrest> ./build.sh dist
        Using classpath: "./lib/endorsed/xalan-2.4.1.jar;./lib/endorsed/xercesImpl-2.1.0
        .jar;./lib/endorsed/xml-apis.jar;./lib/endorsed/xsltc.jar"
        C:\Data\MyDocRalf\bin\cgywin\bin\cygpath.exe: *** can't create title mutex, Win3
        2 error 6
        C:\Data\MyDocRalf\bin\cgywin\bin\cygpath.exe: *** can't create title mutex, Win3
        2 error 6
        Buildfile: build.xml

        init:

              --------------------------------------------------------------

              Using Apache Ant version 1.5.1 compiled on October 2 2002
              Build file c:\data\MyDocRalf\bin\Java\apache_forrest\xml-forrest\build.xml

              Build system home c:\data\MyDocRalf\bin\Java\jars\jakarta-ant-1.5.1
              Build number 4
              Project Name Forrest build file
              Java Version 1.3
              Timestamp 200301100640

              --------------------------------------------------------------


        validate-config:
        validating **/skinconf.xml ...
        Fatal error: exception "java.io.FileNotFoundException" thrown: C:\data\MyDocRalf
        \bin\Java\apache_forrest\xml-forrest\src\resources\schema\relaxng\skinconf-v10.r
        ng (The system cannot find the file specified)

        BUILD FAILED
        file:c:/data/MyDocRalf/bin/Java/apache_forrest/xml-forrest/build.xml:305: Valida
        tion failed, messages should have been provided.

        Total time: 4 seconds
        rhauser@RHAUSERPCGF590K:~/<3>apache_forrest/xml-forrest>
        >>
        Ralf Hauser added a comment -
        I am normally using
        <<Apache Ant version 1.5.1 compiled on October 2 2002>> that uses its share of cygpaths too and I don't run into any problems even with the newer
        "CYGWIN_NT-5.0 RHAUSERPCGF590K 1.3.18(0.69/3/2) 2002-12-25 15:37 i686 unknown unknown Cygwin"

        How would I roll back?

        Anyway, even under win (my "2)" ) it doesn't work due to a different reason. Any idea there?
        Antoine Levy-Lambert added a comment -
        This error message "C:\Data\MyDocRalf\bin\cgywin\bin\cygpath.exe: *** can't create title mutex, Win32 error 6" points to a cygwin installation problem.
        cygpath is a small utility program which can convert paths from cygwin syntax to windows syntax and the contrary.
        cygpath is used in the forrest and ant scripts.
        You should try to fix your cygwin environment.
        Sometimes there is a problem with the setup of cygwin, and you need to repeat it twice.
        I have this version of cygwin on Win2k :
        $ uname -a
        CYGWIN_NT-5.0 DJ0X820J 1.3.9(0.51/3/2) 2002-01-21 12:48 i686 unknown

        and it works like a charm.

          People

          • Assignee:
            Unassigned
            Reporter:
            Ralf Hauser
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development