Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Compile, Core operations
    • Labels:
      None

      Description

      it would be blissful to get our internal Cocoon upgraded to at least use Cocoon-2.1 head.

        Issue Links

          Activity

          Thorsten Scherler added a comment -
          I replaced all related libs:
          ? lib/endorsed/xalan-2.7.1.jar
          ? lib/endorsed/jakarta-regexp-1.5.jar
          ? lib/endorsed/xml-apis-1.3.04.jar
          ? lib/endorsed/xercesImpl-2.9.1.jar
          ! lib/endorsed/jakarta-regexp-1.4.jar.license.txt
          ! lib/endorsed/xalan-2.7.0.jar
          ! lib/endorsed/xml-apis-1.3.03.jar
          ! lib/endorsed/xercesImpl-2.8.0.jar
          ? lib/core/excalibur-instrument-mgr-impl-2.1.jar
          ? lib/core/cocoon-chaperon-block.jar
          ? lib/core/cocoon-auth-block.jar
          ? lib/core/cocoon-2.1.12-dev.jar
          ? lib/core/excalibur-sourceresolve-2.2.3.jar
          ? lib/core/excalibur-instrument-mgr-api-2.1.jar
          ? lib/core/js-1.6R5.jar
          ? lib/core/jdtcore-3.1.0.jar
          ? lib/core/log4j-1.2.14.jar
          ? lib/core/cocoon-template-block.jar
          ? lib/core/commons-collections-3.2.jar
          ? lib/core/cocoon-linkrewriter-block.jar
          ? lib/core/cocoon-profiler-block.jar
          ? lib/core/nekohtml-0.9.5.jar
          ? lib/core/pizza-1.1.jar
          ? lib/core/cocoon-validation-block.jar
          ? lib/core/cocoon-batik-block.jar
          ? lib/core/cocoon-html-block.jar
          ? lib/core/excalibur-component-2.1.jar
          ? lib/core/cocoon-lucene-block.jar
          ? lib/core/cocoon-fop-block.jar
          ? lib/core/cocoon-asciiart-block.jar
          ? lib/core/javacImpl-0.9.jar
          ? lib/core/ehcache-1.2.3.jar
          ? lib/core/cocoon-xsp-block.jar
          ? lib/core/javacApi-0.9.jar
          ? lib/core/excalibur-instrument-mgr-http-2.1.jar
          ? lib/core/commons-beanutils-core-1.7.0.jar
          ? lib/core/commons-lang-2.4.jar
          ! lib/core/cocoon-asciiart-block-2.2.0-dev.jar
          ! lib/core/ehcache-1.2.jar
          ! lib/core/cocoon-profiler-block-2.2.0-dev.jar
          ! lib/core/cocoon-validation-block-2.2.0-dev.jar
          ! lib/core/cocoon-batik-block-2.2.0-dev.jar
          ! lib/core/cocoon-chaperon-block-2.2.0-dev.jar
          ! lib/core/cocoon-html-block-2.2.0-dev.jar
          ! lib/core/commons-collections-3.1.jar
          ! lib/core/cocoon-fop-block-2.2.0-dev.jar
          ! lib/core/cocoon-2.2.0-dev.jar
          ! lib/core/cocoon-xsp-block-2.2.0-dev.jar
          ! lib/core/cocoon-template-block-2.2.0-dev.jar
          ! lib/core/cocoon-linkrewriter-block-2.2.0-dev.jar
          ! lib/core/excalibur-sourceresolve-2.1.jar
          ! lib/core/commons-lang-2.1.jar
          ! lib/core/cocoon-lucene-block-2.2.0-dev.jar
          Thorsten Scherler added a comment -
          I needed to tweak two classes:
          Index: main/java/org/apache/forrest/util/IdGeneratorTransformer.java
          ===================================================================
          --- main/java/org/apache/forrest/util/IdGeneratorTransformer.java (revision 680993)
          +++ main/java/org/apache/forrest/util/IdGeneratorTransformer.java (working copy)
          @@ -133,7 +133,7 @@
               }
           
               public void service(ServiceManager manager) throws ServiceException {
          - super.service(manager);
          + //super.service(manager);
                   try {
                       this.processor = (XPathProcessor)this.manager.lookup(XPathProcessor.ROLE);
                   } catch (Exception e) {

          Index: main/java/org/apache/forrest/util/XPathTransformer.java
          ===================================================================
          --- main/java/org/apache/forrest/util/XPathTransformer.java (revision 680993)
          +++ main/java/org/apache/forrest/util/XPathTransformer.java (working copy)
          @@ -105,7 +105,7 @@
           
           
               public void service(ServiceManager manager) throws ServiceException {
          - super.service(manager);
          + //super.service(manager);
                   try {
                       this.processor = (XPathProcessor)this.manager.lookup(XPathProcessor.ROLE);
                   } catch (Exception e) {
          Thorsten Scherler added a comment -
          Neither mode is running:

          Exception in thread "main" org.apache.avalon.framework.component.ComponentException: Could not find component (key [org.apache.cocoon.Processor])
          at org.apache.avalon.excalibur.component.ExcaliburComponentManager.lookup(ExcaliburComponentManager.java:245)
          at org.apache.cocoon.components.CocoonComponentManager.lookup(CocoonComponentManager.java:354)
          at org.apache.cocoon.Cocoon.initialize(Cocoon.java:348)
          at org.apache.avalon.framework.container.ContainerUtil.initialize(ContainerUtil.java:244)
          at org.apache.cocoon.bean.CocoonWrapper.initialize(CocoonWrapper.java:177)
          at org.apache.cocoon.bean.CocoonBean.initialize(CocoonBean.java:102)
          at org.apache.cocoon.Main.main(Main.java:320)
          Caused by: org.apache.avalon.framework.configuration.ConfigurationException: Cannot resolve sitemap.xmap
          at org.apache.cocoon.components.treeprocessor.TreeProcessor.configure(TreeProcessor.java:204)
          at org.apache.avalon.framework.container.ContainerUtil.configure(ContainerUtil.java:201)
          at org.apache.avalon.excalibur.component.DefaultComponentFactory.newInstance(DefaultComponentFactory.java:289)
          at org.apache.avalon.excalibur.component.ThreadSafeComponentHandler.initialize(ThreadSafeComponentHandler.java:108)
          at org.apache.avalon.excalibur.component.ExcaliburComponentManager.lookup(ExcaliburComponentManager.java:236)
          ... 6 more
          Caused by: org.apache.excalibur.source.SourceException: Unable to select source factory for 'sitemap.xmap'. No default factory found.
          at org.apache.excalibur.source.impl.AbstractSourceResolver.resolveURI(AbstractSourceResolver.java:161)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:585)
          at org.apache.avalon.excalibur.component.ComponentProxyGenerator$ComponentInvocationHandler.invoke(ComponentProxyGenerator.java:143)
          at $Proxy1.resolveURI(Unknown Source)
          at org.apache.cocoon.components.CocoonComponentManager.resolveURI(CocoonComponentManager.java:558)
          at org.apache.cocoon.components.CocoonComponentManager.resolveURI(CocoonComponentManager.java:541)
          at org.apache.cocoon.components.treeprocessor.TreeProcessor.configure(TreeProcessor.java:202)
          ... 10 more
          Java Result: 1
          David Crossley added a comment -
          Do the notes help that i made in FOR-955? It seems that i got further than you have.
          David Crossley added a comment -
          Discussion and testing moved to FOR-955
          David Crossley added a comment -
          Closing this duplicate of FOR-955

            People

            • Assignee:
              Unassigned
              Reporter:
              Thorsten Scherler
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development