Forrest
  1. Forrest
  2. FOR-1020

Indexing and Exploring multiple FOAF files

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.9
    • Fix Version/s: None
    • Component/s: Plugin: input.foaf
    • Labels:
      None
    • Urgency:
      Normal

      Description

      When multiple FOAF files are present, it should be possible to index those and explore the data as in the FOAF explorer [1].

      [1] http://xml.mfd-consult.dk/foaf/explorer/
      1. images.zip
        33 kB
        Oshani Seneviratne
      2. FOR-1020_12082007.patch
        14 kB
        Oshani Seneviratne

        Activity

        Oshani Seneviratne added a comment -
        foaf_indexing.patch contains:

        1. Code for indexing multiple FOAF files along with a sample
        2. The fix for FOR-1008 (XDoc produced by foaf-to-document.xsl is not valid)
        Gavin added a comment -
        I applied the patch locally and tested. Although it builds and runs when doing a 'forrest run' it does not build a site when running 'forrest' and it does not pass the 'ant test' .

        Please run 'ant test' from the plugin directory. (If forrest's ant is not in your system path then run %forrest_home%/tools/ant/bin/ant test) .

        You will see some build errors, see if you can fix those and supply a new patch. Everyone should do an 'ant test' when modifying plugins in case errors creep in that might otherwise get missed.

        I would also like to see the *.rdf files moved somewhere else, I dont think they should be in the root dir of the plugin. Perhaps create an /rdf/ dir in /src/documention/content or alternatively in /resources/rdf/ -- not sure what others think here?

        The project-logo.png, group-logo and favicon.ico files are missing from the xdocs/images directory, can you copy those from another plugin and add them to your patch. I thought that when a plugin was created that those images were added automatically, perhaps something is wrong with our plugin generation, needs verifying.

        Gavin added a comment -
        Part 2 of this fix relating to FOR-1008 seems fine and will apply that separatly, you may need to delete your foaf-to-document.xsl and re-download it from SVN to keep up with the version numbering before applying your other fixes for this issue.
        Oshani Seneviratne added a comment -
        images.zip contains the images which are missing from
        ${FORREST_HOME}/whiteboard/plugins/org.apache.forrest.plugin.input.foaf/src/documentation/content/xdocs/images

        Please copy these files (project.png, project-logo.gif, icon.png and favicon.ico) to the above location.

        Also project.svg and group.svg should be removed from there.

        Gavin added a comment -
        Have applied the images, issue still open to await the rest of the patches.
        Oshani Seneviratne added a comment -
        Thanks for applying the images.

        Please check and apply the patch I've submitted to FOR-1008 [1]. Since the changes required to resolve this issue involves files modified there, it has to be applied first.

        [1] https://issues.apache.org/jira/secure/attachment/12363540/valid_xdoc.patch
        Gavin added a comment -
        Yep, sorry my fault, I have now applied that fix and the issue is closed, so this issue can be looked at.

        The plugin still fails an 'ant test' (Not due to xdocs validation - that is fine) . The plugin will not build due to one error I can see :-

             [java] X [0] oshani BROKEN: No pipeline matched request: oshani

        Doing a 'forrest run' within the plugin works fine :
        Taking a look at http://localhost:8888/personDetails.html I see a link to 'http://localhost:8888/oshani' .

        This link is made in the foaf-to-document.xsl. I don't know what plans you have for this link?
        Oshani Seneviratne added a comment -
        Hmm.. strange! This couldn't have been because I removed rdf:ID="oshani" from the foaf.xml file. Also before submitting this patch I ran 'ant test' and 'forrest', and it was successful. However, now with r564578 both of them seem to be failing. I suspect the reason to be a change I did in the locationmap.xml in my earlier patch - "foaf_indexing.patch". I think that you have applied the "valid_xdoc.patch" on top of that. But actually I was under the assumption that you would completely disregard my earlier patch. So I worked on a fresh svn checkout and took the new patch (i.e. "valid_xdoc.patch") on that. Anyway, in my next patch I will make the necessary changes to locationmap.xml to fix this. No problem!

        However as you pointed out, I have a link pointing to http://localhost:8888/${RDF_ID_ATTRIBUTE_VALUE} in the foaf-to-document.xsl. I kept it in the "valid_xdoc.patch" since I have plans of using it in indexing FOAF files (it is not related to FOR-1008 though).

        Oshani Seneviratne added a comment -
        FOR-1020_12082007.patch

        This patch includes code and a sample for indexing multiple FOAF files.
        Gavin added a comment -
        Patch Applied, thanks - looking good.

          People

          • Assignee:
            Unassigned
            Reporter:
            Oshani Seneviratne
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development