Uploaded image for project: 'FOP'
  1. FOP
  2. FOP-997

Setting the property "width" on cell does not take effect.

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 0.20.5
    • Fix Version/s: None
    • Component/s: layout/unqualified
    • Labels:
      None
    • Environment:
      Operating System: other
      Platform: Other
    • External issue ID:
      35656

      Description

      In the attached XSL-FO, the table has three columns whose widths are all set
      to 1in. And I set the property width of the cell which is located in the first
      row and the second column to 2in. However the produced PDF shows that the
      widths of the three columns are still equal and the property "width" on cell
      does not take effect.

      1. ResultFO2PDF.pdf
        1 kB
        maco
      2. report.fo
        2 kB
        maco

        Issue Links

          Activity

          gadams Glenn Adams added a comment -

          batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed

          adelmelle@apache.org Andreas L. Delmelle added a comment -
          manuel Manuel Mall added a comment -
              • FOP-1154 has been marked as a duplicate of this bug. ***
          jeremias@apache.org Jeremias Maerki added a comment -

          FOP doesn't support getting column widths from the first table row as
          described in http://www.w3.org/TR/CSS2/tables.html#width-layout, yet. Even the
          current development code doesn't do that, yet.

          As a work-around you'll have to specify the column widths directly on the
          table-column nodes instead.

          I'll leave the bug open as a reminder to implement that in FOP trunk.

          forevertraveller@hotmail.com maco added a comment -

          Attachment ResultFO2PDF.pdf has been added with description: pdf file

          forevertraveller@hotmail.com maco added a comment -

          Attachment report.fo has been added with description: fo file


            People

            • Assignee:
              fop-dev@xmlgraphics.apache.org fop-dev
              Reporter:
              forevertraveller@hotmail.com maco
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development