Fop
  1. Fop
  2. FOP-1114

break-before (picture, even-page?) strange behaviour

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: trunk
    • Fix Version/s: None
    • Component/s: page-master/layout
    • Labels:
      None
    • Environment:
      Operating System: other
      Platform: Other
    • External issue ID:
      37964

      Description

      break-before="even-page" works correct in many cases. But in this one it behaves
      strang: After a odd page (<fo:block break-before="odd-page">some text</fo:block>
      and containing a picture) i failed to set the next page to an even page using
      <fo:block break-before="even-page">.x.x.</fo:block>.

      There comes an empty page. But it contains static content that should not be,
      because i defined a layout for empty pages that should show nothing and that
      worked in other places. It looks like fop thinks that there is some content.

      After this (unwanted not realy empty) page the page with the .x.x. content is
      rendered but this is an odd page!

      The dummy-text was intended as a work-around for the not yet implementetd
      force-page-count="end-on-even"

      1. dorfchronik.fo
        8 kB
        gerhard oettl

        Activity

        gerhard oettl added a comment -

        Attachment dorfchronik.fo has been added with description: the corresponding fo-file

        Jeremias Maerki added a comment -

        Bug fixed: http://svn.apache.org/viewcvs?rev=357942&view=rev

        Thanks for reporting!

        Glenn Adams added a comment -

        batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed


          People

          • Assignee:
            fop-dev
            Reporter:
            gerhard oettl
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development