Flume
  1. Flume
  2. FLUME-959

Change flume deps to Apache Hadoop from CDH version of Hadoop

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: v0.9.4
    • Fix Version/s: v0.9.5
    • Component/s: Build
    • Labels:

      Description

      Currently flume depends on CDH hadoop-core, not sure why.

      From pom.xml in trunk:

          <profile>
            <id>hadoop-0.20.2-CDH3B4</id>
            <activation>
              <property>
                <name>!hadoop.profile</name>
              </property>
            <activeByDefault>true</activeByDefault>
            </activation>
            <properties>
              <hadoop.version>0.20.2-CDH3B4</hadoop.version>
              <hadoop.common.artifact.id>hadoop-core</hadoop.common.artifact.id>
              <FlushingSeqFile>bar.java</FlushingSeqFile>
              <RawSeqFile>foo.java</RawSeqFile>
            </properties>
            <dependencyManagement>
              <dependencies>
                <dependency>
                  <groupId>org.apache.hadoop</groupId>
                  <artifactId>${hadoop.common.artifact.id}</artifactId>
                  <version>${hadoop.version}</version>
                </dependency>
              </dependencies>
            </dependencyManagement>
          </profile>
      

      This should be hadoop-1?

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              Arun C Murthy
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development