Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-922

Straighten up branches for development

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 0.9.4, 1.0.0
    • 0.9.5, 1.1.0
    • Technical Debt
    • None

    Description

      FLUME-728 was very useful when developing Flume 1.0.0, but now it's quite confusing to do post 1.0.0 development on a FLUME-728 branch, while 0.9.X is done on trunk.
      So this ticket is about figuring out the best way to go forward.

      Here are some questions:

      • Is there going to be maintenance release of 1.1.X or is it unnecessary given that Flume 1.X is still qualified as alpha quality by its community?
      • Will most of the development happen on the FLUME-728 (or whatever new name, if needed) or is there a need for a separate branch for trunk / 1.X / 1.0.X?

      Note: I can also volunteer on doing some of the work

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            aprabhakar Arvind Prabhakar
            bmahe Bruno Mahé
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment