Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Implemented
    • Affects Version/s: NG alpha 1
    • Fix Version/s: v1.3.0
    • Component/s: Channel
    • Labels:
      None

      Description

      Implement write ahead logging as a separate library that can be used in a file channel.

        Activity

        E. Sammer created issue -
        E. Sammer made changes -
        Field Original Value New Value
        Component/s Channel [ 12316614 ]
        E. Sammer added a comment -

        I've pushed what I have thus far out onto the flume-897 branch. It's a work in progress.

        E. Sammer made changes -
        Fix Version/s v1.1.0 [ 12319284 ]
        Fix Version/s v1.0.0 [ 12318896 ]
        Juhani Connolly added a comment -

        I'm curious if there is any progress or plans to work on this issue and its parent?

        I think that the file channel is one of the major missing components from NG right now, yet these two issues seem to have fallen by the wayside... I understand that they're pretty hairy(I certainly found the threading issues with the memory channel to be so too).

        If we can bounce ideas and E. Sammer is too busy to work on it, I could give it a shot if no-one else is interested, as I feel that the file channel is an impoprtant component to have, and necessary if we want to replicate something like buffers in scribe.

        Arvind Prabhakar made changes -
        Fix Version/s v1.2.0 [ 12320243 ]
        Fix Version/s v1.1.0 [ 12319284 ]
        Mike Percy made changes -
        Fix Version/s v1.3.0 [ 12322140 ]
        Fix Version/s v1.2.0 [ 12320243 ]
        Hari Shreedharan added a comment -

        Eric - I am closing this out, as the File Channel has been implemented, and was a part of the 1.2.0 release.

        Please let me know if this was intended as a more generic WAL solution. Feel free to reopen if needed. Thanks!

        Hari Shreedharan made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Implemented [ 10 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        225d 1h 13m 1 Hari Shreedharan 31/Jul/12 07:08

          People

          • Assignee:
            E. Sammer
            Reporter:
            E. Sammer
          • Votes:
            4 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development