Flume
  1. Flume
  2. FLUME-411

Events sent down each branch of a FanOut sink should be independent

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: v0.9.3
    • Component/s: None
    • Labels:
      None

      Description

      Currently, if an event is sent down two paths that annotate the event, because the same instance of the event is used, there may be an unexpected attribute overwrite exception.

      Examples:

      [

      {value("foo","bar") => console} , {value("baz", "blah") => console} ]

      This would output something like:

      event {foo:bar}
      event {foo:bar, baz:blah}

      Notice that the foo attribute is on the second event!

      For this example
      [ {value("foo","bar") => console}

      ,

      {value("foo", "failure") => console}

      ]

      The first would succeed but the second branch would fail because foo is being overwritten!

        Issue Links

          Activity

          Jonathan Hsieh created issue -
          Jonathan Hsieh added a comment -

          I think this is the root cause for FLUME-265.

          Jonathan Hsieh made changes -
          Field Original Value New Value
          Link This issue relates to FLUME-265 [ FLUME-265 ]
          Jonathan Hsieh made changes -
          Assignee Jonathan Hsieh [ jmhsieh ]
          Jonathan Hsieh added a comment -
          Jonathan Hsieh made changes -
          Attachment 0001-FLUME-411-FanOut-doesn-t-support-multiple-collectorS.patch [ 10370 ]
          Attachment License Granted license to ASF [ licensed ]
          Jonathan Hsieh made changes -
          Status Open [ 1 ] Patch Available [ 10000 ]
          Jonathan Hsieh added a comment -

          committed

          Jonathan Hsieh made changes -
          Status Patch Available [ 10000 ] Resolved [ 5 ]
          Fix Version/s v0.9.3 [ 10040 ]
          Resolution Fixed [ 1 ]
          Mark Thomas made changes -
          Project Import Tue Aug 02 16:57:12 UTC 2011 [ 1312304232406 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Blocked Blocked
          26m 27s 1 Jonathan Hsieh 19/Dec/10 02:46
          Blocked Blocked Resolved Resolved
          1d 20h 3m 1 Jonathan Hsieh 20/Dec/10 22:50

            People

            • Assignee:
              Jonathan Hsieh
              Reporter:
              Jonathan Hsieh
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development