Flume
  1. Flume
  2. FLUME-332

Make plugin installation packaging friendly.

    Details

    • Type: New Feature New Feature
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: v0.9.4
    • Fix Version/s: None
    • Component/s: Build
    • Labels:
      None

      Description

      Ideally installing and configuring flume to use a plugin should be as easy as installing deb/rpm. Currently we need to modify a configuration file to enable this.

      It seems like many services have a "drop dir" where which are seem like easy places to drop plugin settings without having to modify another file. This seems like a simple and appropriate way to do this for flume plugins.

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              Jonathan Hsieh
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:

                Development