Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.0
    • Fix Version/s: 1.9.0
    • Component/s: None
    • Labels:
      None

      Description

      Kafka client 2.0 has been out for a while. It would be nice to use a more recent client.
      Flume uses the Kafka client and the server libraries. Server libraries are required for offset migration. Offset migration should be marked deprecated so Flume 2.0 could get rid of the Kafka server dependencies.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                emajor Endre Major
                Reporter:
                emajor Endre Major
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Due:
                  Created:
                  Updated:
                  Resolved: