Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-3115

Upgrade netty library dependency

    XMLWordPrintableJSON

    Details

    • Type: Dependency upgrade
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.7.0
    • Fix Version/s: 1.8.1, 1.9.0
    • Component/s: None
    • Labels:

      Description

      Group Artifact Version used Upgrade target
      io.netty netty 3.2.2.Final, 3.9.4.Final 4.1.12.Final

      Note: This artifact was moved to:

      • New Group io.netty
      • New Artifact netty-all

      Security vulnerability: http://www.cvedetails.com/cve/CVE-2014-3488/

      Please do:

      • double check the newest version.
      • consider to remove a dependency if better alternative is available.
      • check whether the lib change would introduce a backward incompatibility (in which case please add this label `breaking_change` and fix version should be the next major)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                fszabo Ferenc Szabo
                Reporter:
                sati Attila Simon
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: