Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-2573

flume-ng --conf parameter is not used when starting a flume agent

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.7.0
    • Component/s: Node
    • Labels:
    • Environment:

      ubuntu 12 & Flume 1.4.0

      Description

      flume-ng script accepts the parameter conf to pass the directory which stores the configuration files and adds it to the FLUME_CLASSPATH. But org.apache.flume.node.Application expects configuration files passed to have an absolute path. So even if user passes `conf` and `conf-file` option, `application` looks for the configuration file in the directory from which it is executed. It would be good to take the `conf` value into consideration so that users can place the config files anywhere.

      Currently big-top init.d script joins the `conf` and `conf-file` values when calling flume-ng. The same can be done in the ` flume-ng ` script. Alternatively the `conf ` parameter can be read in ` application ` and concatenated in the code. The latter is a cleaner approach but will have impact on ` big-top `.

        Activity

        bessbd Bessenyei Balázs Donát added a comment -

        There has been no action on this ticket in the last few weeks, I suggest marking this ticket as resolved ("Not a bug").
        (Reason: this ticket blocks release of Flume 1.7.0 and it doesn't seem to be a bug.)

        Are there any objections to marking the ticket as resolved?

        bessbd Bessenyei Balázs Donát added a comment -

        Biju Nair: can you please explain why this change is exactly needed? Some elaboration on the "The latter is a cleaner approach but will have impact on ` big-top `." would be super helpful.

        Otherwise if the patch is applied in its current form, it breaks all current systems where people use the -f (config file) with absolute path. As it's passed over from the flume-ng script. (Also, the --conf command line arguments serve different purposes in the bash script and the java program)

        Collaborators: Denes Arvay, Attila Simon

        gsbiju Biju Nair added a comment -

        Hi Hari Shreedharan any comments on the patch provided?

        gsbiju Biju Nair added a comment -

        Patch file attached since Flume project doesn't accept GIT PRs.

        hshreedharan Hari Shreedharan added a comment -

        Flume does not accept Pull requests via Github. Can you please create a patch and attach it to this jira? Thanks!

        githubbot ASF GitHub Bot added a comment -

        GitHub user bijugs opened a pull request:

        https://github.com/apache/flume/pull/10

        Changes to accept directory which stores config file as one of the param

        Fix for FLUME-2573(https://issues.apache.org/jira/browse/FLUME-2573)

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/bijugs/flume FLUME-2573

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/flume/pull/10.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #10


        commit ec44f043fc349e86edc301dfc6c4dfdfd8e423f0
        Author: Biju Nair <bnair10@bloomberg.net>
        Date: 2014-12-13T16:57:48Z

        Changes to accept directory which stores config file as one of the parameters to run agents : FLUME-2573



          People

          • Assignee:
            Unassigned
            Reporter:
            gsbiju Biju Nair
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development