Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-2531

Upgrade Thrift to 0.9.1

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Thrift 0.9+ is needed for some sinks (e.g. Cassandra) but just upgrading the dependency version breaks compilation and backwards compatibility with the Hadoop 1 profile.

      It would be great to find a way to update it while preserving compatibility.

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              smolav Santiago M. Mola

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment