Uploaded image for project: 'Flume'
  1. Flume
  2. FLUME-2012

Two tests fail on Mac OS (saying they fail to load native library) with Java 7

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Mac OS X, 10.8.3, 64-bit

      Description

      Avro could be configured to use snappy compression. Snappy is implemented using JNI and native libraries. Even though snappy is supposed to have support for Mac OS, two tests fail saying "FAILED_TO_LOAD_NATIVE_LIBRARY".

      1. FLUME-2012.patch
        3 kB
        Thiruvalluvan M. G.

        Activity

        hudson Hudson added a comment -

        Integrated in flume-trunk #399 (See https://builds.apache.org/job/flume-trunk/399/)
        FLUME-2012. Two tests fail on Mac OS (saying they fail to load native library) with Java 7. (Revision 1da1e53248910efb18ad9207df963335da4d19de)

        Result = UNSTABLE
        mpercy : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=1da1e53248910efb18ad9207df963335da4d19de
        Files :

        • flume-ng-core/src/test/java/org/apache/flume/serialization/TestSyslogAvroEventSerializer.java
        • flume-ng-core/src/test/java/org/apache/flume/serialization/TestFlumeEventAvroEventSerializer.java
        mpercy Mike Percy added a comment -

        Pushed to trunk and flume-1.4 branches. Thanks Thiruvalluvan M. G.!

        mpercy Mike Percy added a comment -

        +1, I do not run OpenJDK 7 but this looks good to me and the tests still run fine on Mac Oracle JDK6.

        thiru_mg Thiruvalluvan M. G. added a comment -

        A proper solution is to resolve the root cause, which is https://github.com/xerial/snappy-java/issues/6

        The resolution has not made it to a release. It is only available in milestone builds. So, until the problem is resolved and a new release becomes available, the two offending can be disabled only for Mac OS X and Java 1.7. The patch does just that.


          People

          • Assignee:
            thiru_mg Thiruvalluvan M. G.
            Reporter:
            thiru_mg Thiruvalluvan M. G.
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development