Flume
  1. Flume
  2. FLUME-1948

plugins.d directory(ies) should be separately overridable, independent of FLUME_HOME

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: v1.3.1
    • Fix Version/s: v1.4.0
    • Component/s: Configuration
    • Labels:
      None

      Description

      We should be able to configure where the plugins.d directory is.

      1. FLUME-1948-3.patch
        3 kB
        Mike Percy
      2. flume.pluginsd-test.properties
        0.9 kB
        Mike Percy
      3. test-sink.tar.gz
        2 kB
        Mike Percy
      4. test-interceptor.tar.gz
        2 kB
        Mike Percy

        Issue Links

          Activity

          Mike Percy added a comment -

          Taking this one

          Mike Percy added a comment -

          Added a command-line option to allows specifying one or more directories to be used as a plugins.d directory

          Mike Percy added a comment -

          Attaching the test plugins and conf file I used for manual verification

          Jarek Jarcec Cecho added a comment -

          I've committed the patch to trunk and cherry picked to flume-1.4 branch.

          Thank you Mike!

          Jarcec

          Mike Percy added a comment -

          Thanks for the commit Jarcec!

          Hudson added a comment -

          Integrated in flume-trunk #392 (See https://builds.apache.org/job/flume-trunk/392/)
          FLUME-1948: plugins.d directory(ies) should be separately overridable, independent of FLUME_HOME (Revision 961b995a0432a58d43a01a3ca537ecb153d99b22)

          Result = UNSTABLE
          jarcec : http://git-wip-us.apache.org/repos/asf/flume/repo?p=flume.git&a=commit&h=961b995a0432a58d43a01a3ca537ecb153d99b22
          Files :

          • bin/flume-ng
          Jarek Jarcec Cecho added a comment -

          The test failure do not seem to be caused by this patch as it was failing in previous build as well.


            People

            • Assignee:
              Mike Percy
              Reporter:
              Hari Shreedharan
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development