Flume
  1. Flume
  2. FLUME-1125

flume-ng script allows flume-env.sh to clobber some command-line arguments

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: v1.1.0
    • Fix Version/s: v1.2.0
    • Component/s: None
    • Labels:
      None

      Description

      Certain command-line arguments such as --classpath and -D* can be clobbered by specifying them as FLUME_CLASSPATH and JAVA_OPTS in flume-env.sh

      These command-line params should append to the values specified in the flume-env.sh script, if any.

        Issue Links

          Activity

          Mike Percy created issue -
          Mike Percy made changes -
          Field Original Value New Value
          Attachment FLUME-1125-4.patch [ 12523055 ]
          Mike Percy made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Brock Noland made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Mike Percy made changes -
          Link This issue breaks FLUME-1130 [ FLUME-1130 ]

            People

            • Assignee:
              Mike Percy
              Reporter:
              Mike Percy
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development