Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: v1.2.0
    • Fix Version/s: None
    • Component/s: Build
    • Labels:
      None
    • Environment:

      [CentOS 6.2 64-bit]

      Description

      Flume NG has duplicate servlet libs in lib dir:

      servlet-api-2.5-20081211.jar
      servlet-api-2.5.jar

      Is this is transitive dep issue? Which one should be used? Just "servlet-api-2.5.jar"?

      For reference, the following are all the libs in Flume's lib dir:

      avro-1.6.1.jar
      avro-ipc-1.6.1.jar
      commons-cli-1.2.jar
      commons-codec-1.3.jar
      commons-collections-3.2.1.jar
      commons-dbcp-1.4.jar
      commons-io-2.1.jar
      commons-lang-2.4.jar
      commons-logging-1.1.1.jar
      commons-pool-1.5.4.jar
      derby-10.8.2.2.jar
      flume-avro-source-1.2.0-incubating-SNAPSHOT.jar
      flume-file-channel-1.2.0-incubating-SNAPSHOT.jar
      flume-hdfs-sink-1.2.0-incubating-SNAPSHOT.jar
      flume-irc-sink-1.2.0-incubating-SNAPSHOT.jar
      flume-jdbc-channel-1.2.0-incubating-SNAPSHOT.jar
      flume-ng-core-1.2.0-incubating-SNAPSHOT.jar
      flume-ng-log4jappender-1.2.0-incubating-SNAPSHOT.jar
      flume-ng-node-1.2.0-incubating-SNAPSHOT.jar
      flume-ng-sdk-1.2.0-incubating-SNAPSHOT.jar
      flume-thrift-source-1.2.0-incubating-SNAPSHOT.jar
      guava-10.0.1.jar
      httpclient-4.0.1.jar
      httpcore-4.0.1.jar
      irclib-1.10.jar
      jackson-core-asl-1.9.3.jar
      jackson-mapper-asl-1.9.3.jar
      jetty-6.1.26.jar
      jetty-util-6.1.26.jar
      jsr305-1.3.9.jar
      libthrift-0.6.1.jar
      log4j-1.2.16.jar
      netty-3.2.6.Final.jar
      paranamer-2.3.jar
      servlet-api-2.5-20081211.jar
      servlet-api-2.5.jar
      slf4j-api-1.6.1.jar
      slf4j-log4j12-1.6.1.jar
      snappy-java-1.0.4.1.jar
      velocity-1.7.jar

        Activity

        Hide
        Ashish Paliwal added a comment -

        Will McQueen Flume 1.4.0 doesn't have duplicate lib. Can this issue can be marked as fixed.

        Show
        Ashish Paliwal added a comment - Will McQueen Flume 1.4.0 doesn't have duplicate lib. Can this issue can be marked as fixed.
        Hide
        Ashish Paliwal added a comment -

        Downloaded 1.2.0 binary and checked, the duplicate servlet api jar is not present.

        Hari Shreedharan Shall we mark this as non-reproducible?

        Show
        Ashish Paliwal added a comment - Downloaded 1.2.0 binary and checked, the duplicate servlet api jar is not present. Hari Shreedharan Shall we mark this as non-reproducible?
        Hide
        Hari Shreedharan added a comment -

        Yes, please do.

        Show
        Hari Shreedharan added a comment - Yes, please do.
        Hide
        Ashish Paliwal added a comment -

        Not able to reproduce the issue. Downloaded 1.2.0 binary, and verified. Only servlet-api-2.5-20110124.jar is present.

        Show
        Ashish Paliwal added a comment - Not able to reproduce the issue. Downloaded 1.2.0 binary, and verified. Only servlet-api-2.5-20110124.jar is present.

          People

          • Assignee:
            Ashish Paliwal
            Reporter:
            Will McQueen
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development