Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-7777

Bump japicmp to 0.11.0

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.5.0
    • Fix Version/s: 1.5.0
    • Component/s: Build System
    • Labels:
      None

      Description

      Currently, flink used japicmp-maven-plugin version is 0.7.0, I'm getting these warnings from the maven plugin during a mvn clean verify:

      [INFO] Written file '.../target/japicmp/japicmp.diff'.
      [INFO] Written file '.../target/japicmp/japicmp.xml'.
      [INFO] Written file '.../target/japicmp/japicmp.html'.
      Warning:  org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not recognized.
      Compiler warnings:
        WARNING:  'org.apache.xerces.jaxp.SAXParserImpl: Property 'http://javax.xml.XMLConstants/property/accessExternalDTD' is not recognized.'
      Warning:  org.apache.xerces.parsers.SAXParser: Feature 'http://javax.xml.XMLConstants/feature/secure-processing' is not recognized.
      Warning:  org.apache.xerces.parsers.SAXParser: Property 'http://javax.xml.XMLConstants/property/accessExternalDTD' is not recognized.
      Warning:  org.apache.xerces.parsers.SAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not recognized.
      

      japicmp fixed in version 0.7.1 : _Excluded xerces vom maven-reporting dependency in order to prevent warnings from SAXParserImpl. _

      The current stable version is 0.11.0, we can consider upgrading to this version.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                yew1eb Hai Zhou
                Reporter:
                yew1eb Hai Zhou
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: