Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.3.0, 1.4.0
    • Component/s: Table API & SQL, Tests
    • Labels:
      None

      Description

      Tests run: 11, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 6.674 sec <<< FAILURE! - in org.apache.flink.table.api.scala.stream.sql.SqlITCase
      testUnnestArrayOfArrayFromTable(org.apache.flink.table.api.scala.stream.sql.SqlITCase)  Time elapsed: 0.289 sec  <<< ERROR!
      org.apache.flink.runtime.client.JobExecutionException: Job execution failed.
      	at org.apache.flink.runtime.jobmanager.JobManager$$anonfun$handleMessage$1$$anonfun$applyOrElse$6.apply$mcV$sp(JobManager.scala:933)
      	at org.apache.flink.runtime.jobmanager.JobManager$$anonfun$handleMessage$1$$anonfun$applyOrElse$6.apply(JobManager.scala:876)
      	at org.apache.flink.runtime.jobmanager.JobManager$$anonfun$handleMessage$1$$anonfun$applyOrElse$6.apply(JobManager.scala:876)
      	at scala.concurrent.impl.Future$PromiseCompletingRunnable.liftedTree1$1(Future.scala:24)
      	at scala.concurrent.impl.Future$PromiseCompletingRunnable.run(Future.scala:24)
      	at akka.dispatch.TaskInvocation.run(AbstractDispatcher.scala:40)
      	at akka.dispatch.ForkJoinExecutorConfigurator$AkkaForkJoinTask.exec(AbstractDispatcher.scala:397)
      	at scala.concurrent.forkjoin.ForkJoinTask.doExec(ForkJoinTask.java:260)
      	at scala.concurrent.forkjoin.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1339)
      	at scala.concurrent.forkjoin.ForkJoinPool.runWorker(ForkJoinPool.java:1979)
      	at scala.concurrent.forkjoin.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:107)
      Caused by: org.apache.flink.api.common.InvalidProgramException: Table program cannot be compiled. This is a bug. Please file an issue.
      	at org.apache.flink.table.codegen.Compiler$class.compile(Compiler.scala:36)
      	at org.apache.flink.table.runtime.CRowCorrelateProcessRunner.compile(CRowCorrelateProcessRunner.scala:35)
      	at org.apache.flink.table.runtime.CRowCorrelateProcessRunner.open(CRowCorrelateProcessRunner.scala:59)
      	at org.apache.flink.api.common.functions.util.FunctionUtils.openFunction(FunctionUtils.java:36)
      	at org.apache.flink.streaming.api.operators.AbstractUdfStreamOperator.open(AbstractUdfStreamOperator.java:111)
      	at org.apache.flink.streaming.api.operators.ProcessOperator.open(ProcessOperator.java:56)
      	at org.apache.flink.streaming.runtime.tasks.StreamTask.openAllOperators(StreamTask.java:377)
      	at org.apache.flink.streaming.runtime.tasks.StreamTask.invoke(StreamTask.java:254)
      	at org.apache.flink.runtime.taskmanager.Task.run(Task.java:702)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.AssertionError: null
      	at org.codehaus.janino.IClass.isAssignableFrom(IClass.java:652)
      	at org.codehaus.janino.UnitCompiler.isWideningReferenceConvertible(UnitCompiler.java:10844)
      	at org.codehaus.janino.UnitCompiler.isMethodInvocationConvertible(UnitCompiler.java:9010)
      	at org.codehaus.janino.UnitCompiler.findMostSpecificIInvocable(UnitCompiler.java:8799)
      	at org.codehaus.janino.UnitCompiler.findMostSpecificIInvocable(UnitCompiler.java:8657)
      	at org.codehaus.janino.UnitCompiler.findIMethod(UnitCompiler.java:8539)
      	at org.codehaus.janino.UnitCompiler.findIMethod(UnitCompiler.java:8441)
      	at org.codehaus.janino.UnitCompiler.compileGet2(UnitCompiler.java:4609)
      	at org.codehaus.janino.UnitCompiler.access$8200(UnitCompiler.java:209)
      	at org.codehaus.janino.UnitCompiler$12.visitMethodInvocation(UnitCompiler.java:3969)
      	at org.codehaus.janino.UnitCompiler$12.visitMethodInvocation(UnitCompiler.java:3942)
      	at org.codehaus.janino.Java$MethodInvocation.accept(Java.java:4874)
      	at org.codehaus.janino.UnitCompiler.compileGet(UnitCompiler.java:3942)
      	at org.codehaus.janino.UnitCompiler.compileGetValue(UnitCompiler.java:5125)
      	at org.codehaus.janino.UnitCompiler.compile2(UnitCompiler.java:3343)
      	at org.codehaus.janino.UnitCompiler.access$5000(UnitCompiler.java:209)
      	at org.codehaus.janino.UnitCompiler$9.visitMethodInvocation(UnitCompiler.java:3322)
      	at org.codehaus.janino.UnitCompiler$9.visitMethodInvocation(UnitCompiler.java:3294)
      	at org.codehaus.janino.Java$MethodInvocation.accept(Java.java:4874)
      	at org.codehaus.janino.UnitCompiler.compile(UnitCompiler.java:3294)
      	at org.codehaus.janino.UnitCompiler.compile2(UnitCompiler.java:2214)
      	at org.codehaus.janino.UnitCompiler.access$1700(UnitCompiler.java:209)
      	at org.codehaus.janino.UnitCompiler$6.visitExpressionStatement(UnitCompiler.java:1445)
      	at org.codehaus.janino.UnitCompiler$6.visitExpressionStatement(UnitCompiler.java:1438)
      	at org.codehaus.janino.Java$ExpressionStatement.accept(Java.java:2848)
      	at org.codehaus.janino.UnitCompiler.compile(UnitCompiler.java:1438)
      	at org.codehaus.janino.UnitCompiler.compileStatements(UnitCompiler.java:1518)
      	at org.codehaus.janino.UnitCompiler.compile(UnitCompiler.java:2950)
      	at org.codehaus.janino.UnitCompiler.compileDeclaredMethods(UnitCompiler.java:1308)
      	at org.codehaus.janino.UnitCompiler.compileDeclaredMethods(UnitCompiler.java:1281)
      	at org.codehaus.janino.UnitCompiler.compile2(UnitCompiler.java:780)
      	at org.codehaus.janino.UnitCompiler.compile2(UnitCompiler.java:431)
      	at org.codehaus.janino.UnitCompiler.access$400(UnitCompiler.java:209)
      	at org.codehaus.janino.UnitCompiler$2.visitPackageMemberClassDeclaration(UnitCompiler.java:385)
      	at org.codehaus.janino.UnitCompiler$2.visitPackageMemberClassDeclaration(UnitCompiler.java:380)
      	at org.codehaus.janino.Java$PackageMemberClassDeclaration.accept(Java.java:1405)
      	at org.codehaus.janino.UnitCompiler.compile(UnitCompiler.java:380)
      	at org.codehaus.janino.UnitCompiler.compileUnit(UnitCompiler.java:354)
      	at org.codehaus.janino.SimpleCompiler.compileToClassLoader(SimpleCompiler.java:413)
      	at org.codehaus.janino.SimpleCompiler.cook(SimpleCompiler.java:209)
      	at org.codehaus.janino.SimpleCompiler.cook(SimpleCompiler.java:200)
      	at org.codehaus.commons.compiler.Cookable.cook(Cookable.java:76)
      	at org.codehaus.commons.compiler.Cookable.cook(Cookable.java:71)
      	at org.apache.flink.table.codegen.Compiler$class.compile(Compiler.scala:33)
      	at org.apache.flink.table.runtime.CRowCorrelateProcessRunner.compile(CRowCorrelateProcessRunner.scala:35)
      	at org.apache.flink.table.runtime.CRowCorrelateProcessRunner.open(CRowCorrelateProcessRunner.scala:59)
      	at org.apache.flink.api.common.functions.util.FunctionUtils.openFunction(FunctionUtils.java:36)
      	at org.apache.flink.streaming.api.operators.AbstractUdfStreamOperator.open(AbstractUdfStreamOperator.java:111)
      	at org.apache.flink.streaming.api.operators.ProcessOperator.open(ProcessOperator.java:56)
      	at org.apache.flink.streaming.runtime.tasks.StreamTask.openAllOperators(StreamTask.java:377)
      	at org.apache.flink.streaming.runtime.tasks.StreamTask.invoke(StreamTask.java:254)
      	at org.apache.flink.runtime.taskmanager.Task.run(Task.java:702)
      	at java.lang.Thread.run(Thread.java:745)
      
      

        Issue Links

          Activity

          twalthr Timo Walther added a comment -

          I also had this issue once. But it is hard to reproduce. I will update the Janino version, this might help. At least I could not get the error again on my machine.

          githubbot ASF GitHub Bot added a comment -

          GitHub user twalthr opened a pull request:

          https://github.com/apache/flink/pull/4010

          FLINK-6753 [table] Fix flaky SqlITCase due to Janino bug

          I hope this fixes the flaky test. Otherwise we have to ask the Janino guys about this error.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/twalthr/flink FLINK-6753

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/flink/pull/4010.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #4010


          commit fba92bf91632e33c84393b79e24fba175b47ee03
          Author: twalthr <twalthr@apache.org>
          Date: 2017-05-29T14:52:19Z

          FLINK-6753 [table] Fix flaky SqlITCase due to Janino bug


          sunjincheng121 sunjincheng added a comment -

          Can you tell me what you did to get this exception? I can do the same action in my side.

          githubbot ASF GitHub Bot added a comment -

          Github user twalthr commented on the issue:

          https://github.com/apache/flink/pull/4010

          Merging this...

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/flink/pull/4010

          twalthr Timo Walther added a comment -

          Fixed in 1.4: 5982ea93f4e5db790b3e1d95c22ecdf2923528d7
          Fixed in 1.3: 144f663bd236c8d5febb1a0478f26c533cab00d1


            People

            • Assignee:
              twalthr Timo Walther
              Reporter:
              Zentol Chesnay Schepler
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development