Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-6674 Update release 1.3 docs
  3. FLINK-6683

building with Scala 2.11 no longer uses change-scala-version.sh

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.3.0
    • Component/s: Build System, Documentation
    • Labels:
      None

      Description

      FLINK-6414 eliminated change-scala-version.sh. The documentation (setup/building.html) needs to be updated to match.

        Issue Links

          Activity

          Hide
          alpinegizmo David Anderson added a comment - - edited

          Would it be possible to also clarify the situation with scala 2.12? If Flink 1.3 cannot be built with 2.12 it would better to say so directly. This is rather vague:

          "Newer versions may be compatible, depending on breaking changes in the language
          features used by Flink, and the availability of Flink’s dependencies in those Scala versions.
          The dependencies written in Scala include for example Kafka, Akka, Scalatest, and scopt."

          Show
          alpinegizmo David Anderson added a comment - - edited Would it be possible to also clarify the situation with scala 2.12? If Flink 1.3 cannot be built with 2.12 it would better to say so directly. This is rather vague: "Newer versions may be compatible, depending on breaking changes in the language features used by Flink, and the availability of Flink’s dependencies in those Scala versions. The dependencies written in Scala include for example Kafka, Akka, Scalatest, and scopt."
          Hide
          StephanEwen Stephan Ewen added a comment -

          +1 to say Scala 2.12 does not work (only 2.10 and 2.11 work at the moment)

          Show
          StephanEwen Stephan Ewen added a comment - +1 to say Scala 2.12 does not work (only 2.10 and 2.11 work at the moment)
          Hide
          StephanEwen Stephan Ewen added a comment -

          The update for the Scala version actually affects the master (1.4) not the 1.3 release, if I see that correctly...

          Show
          StephanEwen Stephan Ewen added a comment - The update for the Scala version actually affects the master (1.4) not the 1.3 release, if I see that correctly...
          Hide
          greghogan Greg Hogan added a comment -
          Show
          greghogan Greg Hogan added a comment - FLINK-6414 was committed to both 1.3 ( 3990d75aaedc8e03ef2facf5732c4a0fe52a7cdc ) and 1.4/master ( 35c087129e2a27c2db47c5ed5ce3fb3523a7c719 ).
          Hide
          StephanEwen Stephan Ewen added a comment -

          Okay, I am confused now. When I browse the code in the release-1.3 branch, I see Scala versions that are not variables and I see the {{chan

          Show
          StephanEwen Stephan Ewen added a comment - Okay, I am confused now. When I browse the code in the release-1.3 branch, I see Scala versions that are not variables and I see the {{chan Non variable Scala versions: https://github.com/apache/flink/blob/release-1.3/flink-runtime/pom.xml#L32 change-scala-version.sh scripe: https://github.com/apache/flink/blob/release-1.3/tools/change-scala-version.sh
          Hide
          greghogan Greg Hogan added a comment -

          Ah, so it was accidentally merged from master and then reverted.

          Show
          greghogan Greg Hogan added a comment - Ah, so it was accidentally merged from master and then reverted.
          Hide
          StephanEwen Stephan Ewen added a comment -

          I think this issue is not valid for 1.3 - as Greg mentioned, 1.3 actually uses that script still to change Scala versions.

          The 1.4 docs are correct.

          Show
          StephanEwen Stephan Ewen added a comment - I think this issue is not valid for 1.3 - as Greg mentioned, 1.3 actually uses that script still to change Scala versions. The 1.4 docs are correct.

            People

            • Assignee:
              Unassigned
              Reporter:
              alpinegizmo David Anderson
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development