Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-6575

Disable all tests on Windows that use HDFS

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0, 1.4.0
    • Fix Version/s: 1.4.0, 1.3.2
    • Component/s: Tests
    • Labels:
      None

      Description

      Similar reasoning as FLINK-6558.

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          GitHub user zentol opened a pull request:

          https://github.com/apache/flink/pull/3891

          FLINK-6575 Disable tests on Windows that use HDFS

          This PR disables all tests on `Windows` that rely on `HDFS`.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/zentol/flink 6575_hdfs_tests

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/flink/pull/3891.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #3891


          commit a5fe66180cae9a03547e7a1badb1af386d754fa2
          Author: zentol <chesnay@apache.org>
          Date: 2017-05-13T10:56:56Z

          FLINK-6575 Disable tests on Windows that use HDFS


          githubbot ASF GitHub Bot added a comment -

          Github user tzulitai commented on the issue:

          https://github.com/apache/flink/pull/3891

          This looks good! +1, merging ...

          githubbot ASF GitHub Bot added a comment -

          Github user tzulitai commented on the issue:

          https://github.com/apache/flink/pull/3891

          One question: I'm curious how the scan for tests that use HDFS was done?

          githubbot ASF GitHub Bot added a comment -

          Github user zentol commented on the issue:

          https://github.com/apache/flink/pull/3891

          I ran the tests repeatedly and analyzed why they failed. For these i determined the cause to be hdfs.

          tzulitai Tzu-Li (Gordon) Tai added a comment -

          Fixed for master via 4cac6f4e64d3a9e5ad0e13e9d6dc29f915b52a18.
          Fixed for 1.3 via 97b53fbc71031106aa15096127710c40e28f3759.

          githubbot ASF GitHub Bot added a comment -

          Github user zentol closed the pull request at:

          https://github.com/apache/flink/pull/3891


            People

            • Assignee:
              Zentol Chesnay Schepler
              Reporter:
              Zentol Chesnay Schepler
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development