Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-5379

Flink CliFrontend does not return when not logged in with kerberos

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.0, 1.3.0
    • Component/s: Client
    • Labels:
      None

      Description

      In pre 1.2 versions, Flink immediately fails when trying to deploy it on YARN and the current user is not kerberos authenticated:

      Error while deploying YARN cluster: Couldn't deploy Yarn cluster
      java.lang.RuntimeException: Couldn't deploy Yarn cluster
      	at org.apache.flink.yarn.AbstractYarnClusterDescriptor.deploy(AbstractYarnClusterDescriptor.java:384)
      	at org.apache.flink.yarn.cli.FlinkYarnSessionCli.run(FlinkYarnSessionCli.java:591)
      	at org.apache.flink.yarn.cli.FlinkYarnSessionCli.main(FlinkYarnSessionCli.java:465)
      Caused by: org.apache.flink.yarn.AbstractYarnClusterDescriptor$YarnDeploymentException: In secure mode. Please provide Kerberos credentials in order to authenticate. You may use kinit to authenticate and request a TGT from the Kerberos server.
      	at org.apache.flink.yarn.AbstractYarnClusterDescriptor.deploy(AbstractYarnClusterDescriptor.java:371)
      	... 2 more
      

      In 1.2, the following happens (the CLI frontend does not return. It seems to be stuck in a loop)

      2016-12-21 13:51:29,925 INFO  org.apache.hadoop.yarn.client.RMProxy                         - Connecting to ResourceManager at my-cluster-2wv1.c.sorter-757.internal/10.240.0.24:8032
      2016-12-21 13:51:30,153 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:51:30,154 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:51:30,154 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:52:00,171 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:52:00,172 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:52:00,172 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:52:30,188 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:52:30,189 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:52:30,189 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:53:00,203 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:53:00,204 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:53:00,204 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:53:30,217 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:53:30,217 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:53:30,218 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:54:00,232 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:54:00,232 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:54:00,232 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:54:30,244 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:54:30,245 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:54:30,245 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:55:00,258 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:55:00,258 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:55:00,259 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:55:30,277 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:55:30,277 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:55:30,277 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:56:00,292 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:56:00,293 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:56:00,293 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:56:30,307 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:56:30,307 WARN  org.apache.hadoop.ipc.Client                                  - Exception encountered while connecting to the server : javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      2016-12-21 13:56:30,307 WARN  org.apache.hadoop.security.UserGroupInformation               - PriviledgedActionException as:longrunning (auth:KERBEROS) cause:java.io.IOException: javax.security.sasl.SaslException: GSS initiate failed [Caused by GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos tgt)]
      

        Issue Links

          Activity

          eronwright Eron Wright added a comment -

          Fixed via PR from FLINK-5364


            People

            • Assignee:
              eronwright Eron Wright
              Reporter:
              rmetzger Robert Metzger
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development