Details

    • Type: Wish
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.2.0, 1.1.3, 1.3.0
    • Fix Version/s: 1.3.0
    • Component/s: None
    • Labels:
      None

      Description

      Is it possible to increase the Scopt version to 3.5.0? This version does also support comma-separated lists of arguments.
      I'm using this in my project and indeed I can use Maven to use the latest Scopt version. But, once I want to deploy an uber-Jar to Flink, it obviously fails because of two different versions of Scopt in the classpath - one in my uber-Jar (Scopt 3.5.0) and the one shipped with Flink distribution (Scopt 3.2.0).

      I know that there is another open issue regarding refactoring the CLI parser (FLINK-1347), but as far as I can see there is no progress yet.

        Activity

        Hide
        StephanEwen Stephan Ewen added a comment -

        Can you try to bump the version, and see that the start/stop scripts still work properly?

        If that works, please let us know or open a pull request.

        Show
        StephanEwen Stephan Ewen added a comment - Can you try to bump the version, and see that the start/stop scripts still work properly? If that works, please let us know or open a pull request.
        Hide
        StephanEwen Stephan Ewen added a comment -

        Fixed via 2c2f3e20e58bcdd81c764d350f12cace24c31f77

        Show
        StephanEwen Stephan Ewen added a comment - Fixed via 2c2f3e20e58bcdd81c764d350f12cace24c31f77

          People

          • Assignee:
            Unassigned
            Reporter:
            LorenzB Lorenz B├╝hmann
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development