Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-4495

Running multiple jobs on yarn (without yarn-session)

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 1.2.0, 1.1.2
    • Component/s: YARN
    • Labels:
      None

      Description

      I created a small application that needs to run multiple (batch) jobs on Yarn and then terminate.

      I essentially do right now the following:

      flink run -m yarn-cluster -yn 10 bla.jar ...

      And in my main I do

      foreach thing I need to do

      { ExecutionEnvironment env = ExecutionEnvironment.getExecutionEnvironment(); env. ... define the batch job. env.execute } In the second job I submit I get an exception: {code}

      java.lang.RuntimeException: Unable to tell application master to stop once the specified job has been finised
      at org.apache.flink.yarn.YarnClusterClient.stopAfterJob(YarnClusterClient.java:184)
      at org.apache.flink.yarn.YarnClusterClient.submitJob(YarnClusterClient.java:202)
      at org.apache.flink.client.program.ClusterClient.run(ClusterClient.java:389)
      at org.apache.flink.client.program.ClusterClient.run(ClusterClient.java:376)
      at org.apache.flink.client.program.ContextEnvironment.execute(ContextEnvironment.java:61)
      at com.bol.tools.hbase.export.Main.runSingleTable(Main.java:220)
      at com.bol.tools.hbase.export.Main.run(Main.java:81)
      at com.bol.tools.hbase.export.Main.main(Main.java:42)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:497)
      at org.apache.flink.client.program.PackagedProgram.callMainMethod(PackagedProgram.java:509)
      at org.apache.flink.client.program.PackagedProgram.invokeInteractiveModeForExecution(PackagedProgram.java:403)
      at org.apache.flink.client.program.ClusterClient.run(ClusterClient.java:331)
      at org.apache.flink.client.CliFrontend.executeProgram(CliFrontend.java:775)
      at org.apache.flink.client.CliFrontend.run(CliFrontend.java:251)
      at org.apache.flink.client.CliFrontend$2.run(CliFrontend.java:995)
      at org.apache.flink.client.CliFrontend$2.run(CliFrontend.java:992)
      at org.apache.flink.runtime.security.SecurityUtils$1.run(SecurityUtils.java:56)
      at java.security.AccessController.doPrivileged(Native Method)
      at javax.security.auth.Subject.doAs(Subject.java:422)
      at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1548)
      at org.apache.flink.runtime.security.SecurityUtils.runSecured(SecurityUtils.java:53)
      at org.apache.flink.client.CliFrontend.parseParameters(CliFrontend.java:992)
      at org.apache.flink.client.CliFrontend.main(CliFrontend.java:1046)
      Caused by: java.util.concurrent.TimeoutException: Futures timed out after [10000 milliseconds]
      at scala.concurrent.impl.Promise$DefaultPromise.ready(Promise.scala:219)
      at scala.concurrent.impl.Promise$DefaultPromise.result(Promise.scala:223)
      at scala.concurrent.Await$$anonfun$result$1.apply(package.scala:107)
      at scala.concurrent.BlockContext$DefaultBlockContext$.blockOn(BlockContext.scala:53)
      at scala.concurrent.Await$.result(package.scala:107)
      at scala.concurrent.Await.result(package.scala)
      at org.apache.flink.yarn.YarnClusterClient.stopAfterJob(YarnClusterClient.java:182)
      ... 25 more

      
      

        Issue Links

          Activity

          mxm Maximilian Michels added a comment -

          Should be resolved with FLINK-4488.

          mxm Maximilian Michels added a comment -

          Thanks Niels Basjes for opening the jira issue. I also created one (FLINK-4488) with an easy fix.


            People

            • Assignee:
              Unassigned
              Reporter:
              nielsbasjes Niels Basjes
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development