Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-4170

Remove `CONFIG_` prefix from KinesisConfigConstants variables

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 1.1.0
    • Connectors / Common
    • None

    Description

      I find the static variable names verbose. I think it's clear from context that they refer to the Kinesis configuration since they are all gathered in that class.

      Therefore would like to remove the CONFIG_ prefix before the release, so that we have

      conf.put(KinesisConfigConstants.AWS_REGION, "")
      

      instead of

      conf.put(KinesisConfigConstants.CONFIG_AWS_REGION, "")
      

      For longer variables it becomes even longer otherwise.

      Some basic variable names that might be accessed frequently are also very long:

      CONFIG_AWS_CREDENTIALS_PROVIDER_BASIC_SECRETKEY
      CONFIG_AWS_CREDENTIALS_PROVIDER_BASIC_ACCESSKEYID
      

      It might suffice to just have:

      AWS_SECRET_KEY
      AWS_ACCESS_KEY
      

      Attachments

        Issue Links

          Activity

            People

              tzulitai Tzu-Li (Gordon) Tai
              uce Ufuk Celebi
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: