I find the static variable names verbose. I think it's clear from context that they refer to the Kinesis configuration since they are all gathered in that class.
Therefore would like to remove the CONFIG_ prefix before the release, so that we have
For longer variables it becomes even longer otherwise.
Some basic variable names that might be accessed frequently are also very long:
It might suffice to just have: