Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-35052

Webhook validator should reject unsupported Flink versions

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Open
    • Major
    • Resolution: Unresolved
    • None
    • None
    • Kubernetes Operator
    • None

    Description

      The admission webhook currently does not verify if FlinkDeployment CR utilizes Flink versions that are not supported by the Operator. This causes the CR to be accepted and the failure to be postponed until the reconciliation phase. We should instead fail fast and provide users direct feedback.

      Attachments

        Activity

          People

            afedulov Alexander Fedulov
            afedulov Alexander Fedulov
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: