Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-22802

Bump Fabric8 Kubernetes Client to >= 5.X

    XMLWordPrintableJSON

Details

    Description

      Hi All, 

      Currently, Flink is using version 4.9.2 of the Fabric8 Kubernetes Client which does not support new versions of the Kubernetes API such as 1.19 or 1.20 as pointed out by their Compatibility Matrix which is support in 5.4.0 or above.

      As far as I have seen in the Flink documentation, Flink supports `Kubernetes >= 1.9.` but due to this dependency, it might not be the case. Is there a plan to update this dependency?

      What is the plan moving forwards when new versions of Kubernetes are released?

      I am raising this because I have been testing Flink HA Session Cluster on Kubernetes 1.19 and 1.20 and I have encountered some frequent errors that force the JM pods to restart or even result in an unrecoverable state.

      Thanks!

      Attachments

        Issue Links

          Activity

            People

              wangyang0918 Yang Wang
              EnriqueL8 Enrique Lacal
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: