The TableEnvironment provides methods to convert DataSets and DataStreams into Tables and back. These methods are called toTable(), toSet(), and toStream().
I propose to rename the methods into fromDataSet(), fromDataStream(), toDataSet(), and toDataStream() for the following reasons:
- fromDataSet(), fromDataStream() is closer to the SQL FROM expression
- It allows to add methods such as fromCSV(), fromHCat(), fromParquet(), and so on to the TableEnvironment
- toSet() and toStream() should be renamed for consistency.