This came to my mind because of the master/slave discussion in FLINK-18209 and
the larger discussions about inequality/civil rights happening right now
in the world. I think for this reason alone we should use a name that
does not include "master".
We could rename it back to JobManager, which was the name mostly used
before 2019. Since the beginning of Flink, TaskManager was the term used
for the worker component/node and JobManager was the term used for the
Currently our glossary defines these terms (paraphrased by me):
- "Flink Master": it's the orchestrating component that consists of
resource manager, dispatcher, and JobManager
- JobManager: it's the thing that manages a single job and runs as
part of a "Flink Master"
- TaskManager: it's the worker process
Prior to the introduction of the glossary the definition of JobManager
would have been:
- It's the orchestrating component that manages execution of jobs and
schedules work on TaskManagers.
Quite some parts in the code and documentation/configuration options
still use that older meaning of JobManager. Newer parts of the
documentation use "Flink Master" instead.
I'm proposing to go back to calling the orchestrating component
JobManager, which would mean that we have to touch up the documentation
to remove mentions of "Flink Master". I'm also proposing not to mention
the internal components such as resource manager and dispatcher in the
glossary because there are transparent to users.
I'm proposing to go back to JobManager instead of an alternative name
also because switching to yet another name would mean many more changes
to code/documentation/peoples minds.