Kostas Kloudas and I are working on an upcoming FLIP that will propose a "real" application mode. The gist of it will be that an application cluster is roughly responsible for all the jobs that are executed in a user main() method. Each individual invocation of execute() in said main() function would launch a job on the aforementioned application cluster. The main() method would run inside the cluster (or not, that's up for discussion).
FLINK-12625 introduced a glossary that describes what was previously known as a "Job Cluster" as an "Application Cluster". We think that in the future users will have both: per-job clusters and application clusters. We therefore think that we should describe our current per-job clusters as Per-job clusters (or job clusters) in the glossary and documentation and reserve the name application cluster for the "real" forthcoming application clusters.
This would also render FLINK-12885 outdated.