Uploaded image for project: 'Flink'
  1. Flink
  2. FLINK-13939

pyflink ExecutionConfigTests#test_equals_and_hash test failed

    XMLWordPrintableJSON

    Details

    • Type: Test
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.9.0
    • Fix Version/s: None
    • Component/s: API / Python, Tests
    • Labels:
      None

      Description

       
      =================================== FAILURES ===================================
       
      669__________________ ExecutionConfigTests.test_equals_and_hash ___________________
       
      670
       
      671self = <pyflink.common.tests.test_execution_config.ExecutionConfigTests testMethod=test_equals_and_hash>
       
      672
       
      673 def test_equals_and_hash(self):
       
      674
       
      675 config1 = ExecutionEnvironment.get_execution_environment().get_config()
       
      676
       
      677 config2 = ExecutionEnvironment.get_execution_environment().get_config()
       
      678
       
      679 self.assertEqual(config1, config2)
       
      680
       
      681> self.assertEqual(hash(config1), hash(config2))
       
      682E AssertionError: 897378335 != 1596606912
       
      683
       
      684pyflink/common/tests/test_execution_config.py:277: AssertionError
       
      685=============================== warnings summary ===============================
       
      686.tox/py37/lib/python3.7/site-packages/py4j/java_collections.py:13
       
      687.tox/py37/lib/python3.7/site-packages/py4j/java_collections.py:13
       
      688.tox/py37/lib/python3.7/site-packages/py4j/java_collections.py:13
       
      689.tox/py37/lib/python3.7/site-packages/py4j/java_collections.py:13
       
      690.tox/py37/lib/python3.7/site-packages/py4j/java_collections.py:13
       
      691 /home/travis/build/flink-ci/flink/flink-python/.tox/py37/lib/python3.7/site-packages/py4j/java_collections.py:13: DeprecationWarning: Using or importing the ABCs from 'collections' instead of from 'collections.abc' is deprecated, and in 3.8 it will stop working
       
      692 from collections import (
       
      693
       
      694-- Docs: https://docs.pytest.org/en/latest/warnings.html
       
      695================== 1 failed, 373 passed, 5 warnings in 34.10s ==================
       
      696ERROR: InvocationError for command /home/travis/build/flink-ci/flink/flink-python/.tox/py37/bin/pytest (exited with code 1)

      more details: https://api.travis-ci.com/v3/job/229979817/log.txt

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                yanghua vinoyang
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: